Editor de Texto

De Wiki Canção Nova
Ir para: navegação, pesquisa
Erro ao criar miniatura: Não foi possível salvar a miniatura no destino
A maioria dos usuários de Macs tende a enxergar o Editor de Texto gratuito que acompanha o Mac OS X como uma espécie de "versão Mac do Bloco de Notas do Windows". Todo mundo sabe que ele é útil, mas geralmente acaba sendo usado apenas pra escrever pequenas anotações rápidas ou pra abrir arquivos de texto simples, como arquivos de log ou documentos "leiame.txt".

O que pouca gente sabe é que por trás desse programinha de aparência humilde se esconde um enorme potencial subutilizado. Quando usado no modo "Texto Normal" ele realmente não impressiona ninguém, pois só gera arquivos de texto sem formatação - os famosos ".TXT". Mas é no modo "Texto com Estilo" que o verdadeiro poder do Editor de Texto se revela: é possível usar várias fontes e estilos no mesmo documento, aplicar efeitos de sombreamento, alinhar texto, criar listas, hyperlinks, tabelas e até inserir imagens! E depois ele deixa você gravar o que criou em vários formatos populares, como RTF ("Rich Text Format"), HTML, PDF e até Word.


Texto Normal x Texto com Estilo

Erro ao criar miniatura: Não foi possível salvar a miniatura no destino
Editor de Texto
A primeira coisa a saber é como alternar entre os dois modos de funcionamento do Editor de Texto. O ideal é trabalhar sempre que possível no modo "Texto com Estilo", pois só assim você terá acesso aos recursos avançados de formatação de texto. Para alternar entre os dois modos, clique no menu "Formato" e depois em "Fazer Texto com Estilo" ou "Fazer Texto Normal", dependendo de qual dos dois modos está ativo no momento (felizmente o default é o primeiro). Ou se preferir, use a combinação de teclas Shift + Command + T para alternar entre os dois modos.



Escolhendo fontes e efeitos

Erro ao criar miniatura: Não foi possível salvar a miniatura no destino
Alterando Fonte
Textos criados no Editor de Texto podem usar fontes e efeitos de formatação semelhantes aos disponíveis para outros editores mais sofisticados, como o Pages. Para escolher a fonte para um segmento de texto, selecione o texto desejado usando o botão esquerdo do mouse e abra a janela de configuração de fontes através do menu "Formato > Fontes > Mostrar fontes" ou pressionando a combinação de teclas Command + T.

Use a janela de configuração para escolher uma fonte específica e um tamanho de texto. Todas as fontes instaladas no sistema estão presentes, e várias delas possuem "variações" de escrita, o que aumenta ainda mais o número de opções disponíveis. Escolhida a fonte e o tamanho desejado, você pode também mudar a cor do texto clicando no quadrado colorido ao lado do "T" na parte de cima da janela. Se quiser, também pode aplicar efeitos de sublinhado ou riscado clicando nos dois primeiros botões da esquerda para a direita.

Escolhida a fonte, tamanho, cor e estilo, resta ainda um truque bem interessante: se o texto selecionado for um título em destaque você pode aplicar um efeito de sombra, que vai dar uma aparência mais profissional ao documento. Para fazer isso selecione o texto desejado e clique no botão com um "T" sombreado, bem no meio da parte de cima da janela de fontes. À direita desse botão há alguns controles adicionais que permitem ajustar a distância da sombra, seu tamanho, sua suavidade e até o grau de incidência da luz, tudo isso em tempo real, mudando o efeito à medida em que você faz os ajustes.


Alinhando e formatando o Texto

Erro ao criar miniatura: Não foi possível salvar a miniatura no destino
Alinhamento do texto
O Editor de Texto permite também fazer configurações no alinhamento visual do documento. Para isso selecione o texto que deseja formatar e clique nos botões correspondentes na parte superior da janela (respectivamente: ajuste à esquerda, central, justificado e à direita).

Outro recurso interessante é a possibilidade de definir o tamanho do recuo no começo de cada parágrafo. Pra fazer isso, posicione o cursor de texto no parágrafo desejado, clique sobre a pequena letra "T" situada imediatamente acima da régua, à esquerda, e arraste-a para a posição que preferir. Da mesma forma, você também pode definir as margens laterais do documento clicando e arrastando os dois pequenos triângulos invertidos localizados no limite esquerdo e direito da régua.

Repare também no controle dropdown "Estilos" situado na barra de ferramentas (o primeiro da esquerda para a direita). Esse controle permite escolher vários estilos pré-definidos para o texto selecionado (padrão, negrito, itálico, sublinhado, riscado). Clicando na opção "Outros" é possível também criar novos estilos personalizados e depois incluí-los na lista padrão.



Listas e Tabelas

Erro ao criar miniatura: Não foi possível salvar a miniatura no destino
Tabelas
O Editor de Texto também é capaz de criar vários tipos de listas, incluindo as tradicionais listas com traços, numeradas ou com "pontos". Para isso, basta clicar no controle "Listas" e escolher o tipo desejado. Você ainda pode criar listas personalizadas clicando no botão "Outra" e definindo um prefixo, um esquema de numeração e um sufixo. Dessa forma é possível, por exemplo, definir um prefixo "imagem", um marcador "1" e um sufixo ".jpg" para gerar automaticamente uma lista de nomes de imagens com incremento numérico (ex: imagem1.jpg, imagem2.jpg, imagem3.jpg, etc).

Outra funcionalidade solenemente ignorada do Editor de Texto é a opção de gerar tabelas. Para criar uma nova tabela abra o menu "Formato", clique em "Texto" e depois em "Tabela". Na janela que surgirá, defina o número de linhas e colunas, o alinhamento horizontal e vertical do texto, a espessura e a cor das bordas, e a cor de fundo padrão das células.

Criada a tabela, basta clicar dentro de uma célula e começar a escrever para adicionar conteúdo, ou pressionar Command + V para colar texto ou imagens copiados de outro local.

E melhor ainda: você pode criar layouts bem interessantes configurando cada célula da tabela individualmente. É só clicar com o botão direito na célula desejada e escolher "Tabela", para que a janela de configuração de tabelas apareça outra vez. No exemplo acima, as células possuem cores de fundo diferentes e algumas delas têm bordas invisíveis (basta definir as bordas com espessura zero). Você também pode fundir células adjacentes selecionando mais de uma célula com Command + clique e clicando em "Combinar células". Ou fazer o contrário, clicando em uma única célula e dividindo-a em duas clicando no botão "Dividir células". E tem mais: se precisar redimensionar as células, é só clicar em seus limites e arrastar até o tamanho desejado.


Salvando seu Trabalho

Agora que você já sabe como usar o Editor de Texto de forma mais efetiva, falta descobrir como salvar corretamente o que você criou nele. O formato padrão dos documentos no modo "Texto com Estilo" é o RTF, mas também é possível gravar no formato Word (compatível com Word 2004 para Mac e Word 2003 para Windows) e no formato Word XML (compatível com o Microsoft Word 2007 para Windows). É bom saber, porém, que a gravação nos formatos compatíveis com o Word não é perfeita, e pode haver perda de parte da formatação do texto. Na verdade, se você criou um documento com layout mais elaborado e precisa compartilhá-lo com outros usuários que não tenham Macs, o melhor a fazer é abrir o menu "Arquivo > Imprimir > PDF" e clicar em "Salvar como PDF". O Editor de Texto irá criar um documento com a extensão PDF (Adobe Reader), que poderá ser aberto facilmente em qualquer plataforma, conservando o layout original intacto.

Tudo o que eu disse no parágrafo anterior vale para os documentos feitos no modo "Texto com Estilo", mas há algumas particularidades diferentes na hora de salvar documentos feitos no modo "Texto Normal". Por exemplo: se você criou um arquivo HTML que possui caracteres acentuados, certifique-se de salvar o arquivo com a codificação de caracteres apropriada. Não entendeu nada? Eu explico: a configuração padrão do Editor é gravar texto normal com a codificação Mac OS Roman. Só que navegadores web (principalmente os usados no Windows), costumam usar outras codificações, principalmente UTF-8 e ISO 8859-1 (Windows Latino 1). Por isso, é bem provável que os visitantes do seu site vejam caracteres truncados onde deveriam ver acentos.

Para evitar isso, lembre-se de escolher a codificação de texto mais apropriada na hora de gravar documentos HTML. Basta escolher "UTF-8" (o padrão mais moderno) ou "Windows Latino 1" (o mais compatível) quando a janela "Salvar" aparecer. Mas há mais um macete importante: informe no cabeçalho do documento HTML qual codificação você escolheu, pois alguns browsers interpretam sempre Windows Latino 1 como padrão. É só inserir uma tag específica dentro da seção "HEAD" do documento, dessa forma: <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> para UTF-8 ou <meta http-equiv="Content-Type" content="text/html; charset=8859-1" /> para Windows Latino 1.

Para evitar que o Editor de Texto coloque automaticamente a extensão .TXT no documento que você criou, clique na opção "Salvar como" dentro do menu "Arquivo" e mude a extensão do documento de .TXT para .HTML. Quando o programa pedir confirmação, clique em "Usar .HTML".


Veja Mais

Mac

Referência

MacMundi